始めに

  外字コピー屋さんは、Windows の外字環境を別のマシンのWindowsにインストールするツールです。

  外字のインストール後に再起動する必要はありません。

  標準の外字だけでなく、各フォントにリンクされた外字もコピーします。つまり、明朝体やゴシック体などで、別の外字を使用している場合でも、リンク情報ごとコピーすることができます。

  本ソフトは、Windows 98 / Me / NT 4.0 / 2000 / XPのいずれかで動作します。外字ファイルは、上記の各OSで共通して使うことができます。（Windows 2000 / XP についてはこちらをお読みください）

  本ソフトを使えば、複数台のマシン間で外字を共通化することが簡単にできます。

  コマンドライン版を使えば、Windows NTドメイン/Active Directoryのログオンスクリプトに使うこともできます。

※ただし、このソフトは外字ファイルが異なるOSで使用できることを保証するものではありません。また、外字を他のPCで使用することや、異なるOS間で共有することは、マイクロソフトのサポート外のことですので、あくまでも自己責任の範囲でお使いください。


インストールとアンインストール

ダウンロード後、ファイルを解凍すると、以下のファイルが出てきます。

cpeudc.exe | 「外字コピー屋さん」のGUI版
cpeu.exe | 「外字コピー屋さん」のコマンドライン版
cpeudc.chm | ヘルプファイル

インストーラは用意しておりません。上記の実行ファイルをお好きなフォルダにコピーしてお使いください。

アンインストールするときは、上記のファイルを削除してください。


使い方

フロッピーディスクやMO、ZIP、メモリディスク等のメディアを用いる場合

ネットワークの共有フォルダを用いる場合

Windows NT 4.0 / 2000 / XP の場合の注意


フロッピーディスクやMO、ZIP、メモリディスク等のメディアを用いる場合

当たり前ですが、いずれのメディアを用いる場合も、コピー元とコピー先の両方のマシンで使用できるものを使用してください。

まず、作業用のメディアを作成します。

フォーマット済みの空のメディアに cpeudc.exe という実行ファイル（「外字コピー屋さん」の本体）をコピーします。これで作業用メディアの作成は完了です。

コピー元マシンの外字を取得する。

1. コピー元マシンに作業用メディアをセットして、Windowsのマイコンピュータから開き、cpeudc.exe をダブルクリックします。すると 「外字コピー屋さん」が起動します。

2. 「このマシンの外字ファイルを取得する」というところにチェックがしてあるのを確認して、[実行(R)]ボタンを押します。すると作業用メディアに外字ファイルがコピーされます。コピーが終わり、メッセージに応答するとプログラムは終了します。

3. 作業用メディアの中に外字ファイルや設定ファイルがコピーされているのを確認してください。

コピー先マシンに外字をインストールする。

1. 作業用メディアを取り出して、コピー先マシンにセットします。

2. コピー先マシンで作業用メディアを開いて、cpeudc.exe を起動してください。

3. 「外字ファイルをこのマシンにインストールする」というところにチェックがしてあるのを確認して、[実行(R)]ボタンを押します。すると、作業用メディアに保存されている外字ファイルが、マシンのシステムフォルダにコピーされます。


ネットワークの共有フォルダを用いる場合

1. cpeudc.exe を共有フォルダにコピーします。

フォルダはどこでもかまいませんが、コピー元マシン上で実行する場合は、読み書き可能、コピー先マシンで実行するには読み込み可能に設定されている必要があります。

2. コピー元マシンで共有フォルダを開いて、cpeudc.exeを実行し外字を取得。

3. コピー先マシンで共有フォルダを開いて、cpeudc.exeを実行し外字のインストール。

という手順になります。


Windows NT 4.0 / 2000 / Xp の場合の注意

ファイルシステムにNTFSを使っている場合、フォントフォルダのセキュリティによっては正常に外字のインストールができない場合があります。

エラーがでた場合は、フォントフォルダへの書き込み権限のあるユーザーでログオンしなお して、再度実行してみてください。

通常はPower User 以上の権限がないと書き込みできないようです。


使い方（応用編）

外字のバックアップ

外字を切り替えて使う

コマンドライン版とログオンスクリプト


外字のバックアップ

外字バックアップ

他のマシンから外字をコピーする前に、現在の外字をバックアップしておくことをお勧めいたします。

やり方は簡単で、cpeudc.exe をハードディスク上の好きなフォルダにコピーして、外字を取得しておくことです。

たとえば、「マイドキュメント」の中に「外字バックアップ」というフォルダを作成し、そこに、cpeudc.exe をコピーします。

「外字バックアップ」フォルダの中のcpeudc.exeを起動して外字を取得しておけば、その後、どんな外字をインストールしても、元に戻すことができます。


外字を切り替えて使う

外字コピー屋さんは、実行中のcpeudc.exe と同じフォルダに、現在の外字ファイルを保存します。

  ですから、複数のフォルダを作り、それぞれcpeudc.exe をコピーしておくことで、その都度外字を切り替えて使うことができるようになります。

  つまり、外字を編集したり他のマシンからコピーしたりするたびに、新しいフォルダを作り、そこにcpeudc.exeをコピーして起動し、外字を取得しておけばよいのです。

  切り替えて使うためには、切り替えたい外字があるフォルダのcpeudc.exeを起動して、外字をインストールしてください。


コマンドライン版とログオンスクリプト

  外字コピー屋さんにはコマンドライン版 が付属します。コマンドライン版は、コマンドプロンプトにて実行するものです。これにより、バッチファイルやログオンスクリプトなどで自動処理することが可能となります。
コマンドライン版の実行ファイル名は、cpeu.exe です。

コマンドラインパラメータ

ログオンスクリプトに使用する


コマンドラインパラメータ

cpeu [/g | /p | true | false ] [/d] [/et | /ef] [/f]

/g | システムにインストールされている外字ファイルを、cpeu.exeと同じディレクトリにコピーする。
/p | cpeu.exeと同じディレクトリにある外字ファイルをシステムにインストールする。なんのメッセージも出さずに上書きインストールしますのでご注意下さい。
/d /p オプションを指定したときのみ有効。
コピー元の外字ファイル、つまりcpeu.exe と同じディレクトリにある外字ファイルの更新日付が、システムにインストールされているものより新しいときだけ、外字をインストールする。
/et | 外字エディタで使用される、*.euf ファイルを操作の対象とする。
/ef | 外字エディタで使用される、*.euf ファイルを操作の対象としない。
/f | ファイル上書きの問い合わせをしない。
true | システムの外字を有効化する
false | システムの外字を無効化する

パラメータになにも指定しなかった場合は、ヘルプを表示します。
間違ったパラメータを指定したときも、ヘルプを表示します。


Windows NTドメインのログオンスクリプトに使用するには

ログオンスクリプトに使用する

Windows NTドメインのログオンスクリプトに使用するには、いずれかの共有フォルダにcpeu.exe を置きます。GUI版のcpeudc.exeも一緒に置いておくと便利です。

このフォルダは、一般ユーザーは読み込みのみ、外字の配布者（管理者）は読み書きできるようにして下さい。

外字の配布者は、cpeu.exe または GUI版の cpeudc.exe をつかって、配布したい外字ファイルを、このフォルダにコピーします。

cpeu /g

Windows NT のログオンスクリプトで、以下のコマンドを記述します。

cpeu /p /d /f

実際にはフルパス名で記述する必要があります。

  こうしておくことによって、一般ユーザーがクライアントマシンからNT ドメインにログオンするたびにこのコマンドが自動的に実行され、コピー元の外字ファイルがクライアントマシンの外字ファイルよりも新しい場合のみ、ファイルの更新が行われます。

[ログオンスクリプトの例]

この例では、NTサーバーのマシン名を NTServer、共有フォルダ名をpub としています。
cpeu.exeは pub のサブフォルダ、cpeudc に置いてあるものとします。

net use Q: \\NTServer\pub
q:\cpeudc\cpeu /p /d /f

なお、ログオンスクリプトそのものに関しては、OSのマニュアルなどを参考にしてください。


動作の詳細

このマシンの外字ファイルを取得する

外字ファイルをインストールする

*.EUFファイルもコピーする

ファイル上書きの問い合わせをしない


取得

このマシンの外字ファイルを取得する

ここにチェックをして[実行(R)]をクリックすると、外字コピー屋さん（cpeudc.exe） と同じフォルダに外字ファイルが取得されます。
このとき、各フォントそれぞれにリンクされている外字ファイルがあれば、すべてコピーされます。また、外字のリンク情報は、eudc.ini というファイルに保存されます。

  コマンドライン版では cpeu /g に相当します。


インストール

外字ファイルをインストールする

外字コピー屋さん（cpeudc.exe） と同じフォルダにあるすべての外字ファイルが、システムにインストールされます。

たとえばWindows 98 の場合は、c:\windows などにコピーされます。Windows NT 4.0/2000/XPの場合は多少複雑で、標準外字ファイル(eudc.*)はフォントフォルダ(c:\windows\fonts など)にコピーされますが、それ以外の外字ファイルは、システムフォルダ(c:\windows など)にコピーされます。

また、ファイルのコピーと同時に、eudc.iniに記録されている外字のリンク情報をレジストリに書き込んで、各フォントにリンクされている外字が使用できるように設定します。書き換えるレジストリキーは[HKEY_CURRENT_USER\EUDC\932]です。

なお、システムにインストールされていないフォントへの外字のリンク情報は書き込みません。

ここがグレー表示になっている場合は、外字のインストールができる状態になっていません。　cpeudc.exeと同じフォルダに、EUDC.INI や外字ファイル ( *.tte )が存在しない場合は、ここはグレー表示になります。

コマンドライン版では cpeu /p に相当します。


*.EUFファイルもコピーする

チェックをはずせば、EUFファイルの取得やインストールを行いませんが、通常は、ここにチェックをしてEUFファイルも操作の対象にするようにしてください。

EUFファイルについては、「EUDC.TTE と EUDC.EUF」を参照してください。

  コマンドライン版の /ef /et スイッチに相当します。


ファイル上書きの問い合わせをしない

チェックすると、外字の取得やインストールの際に、コピー先に同名ファイルがあった場合でも、上書きの問い合わせをしません。
通常はチェックをはずしておいた方が安全です。

  コマンドライン版の /f スイッチに相当します。


外字ファイルについて

Windows の外字ファイルについて

EUDC.TTE と EUDC.EUF

外字のリンク

外字ファイルの保存場所

外字のレジストリ情報


EUDC.TTE と EUDC.EUF

  Windowsの外字ファイルは tte という拡張子を持つファイルと、euf という拡張子を持つファイルのセットになっています。OSに付属する「外字エディタ」で最初に作成される外字ファイルは、eudc.tte と eudc.euf というファイルです。

  なぜ２つのファイルが必要なのでしょうか。

  実は画面に表示するときや印刷の際には、eudc.tte のみが参照されています。このファイルが外字データそのものなのです。

  それでは eudc.euf というファイルは何のためにあるのかというと、それは「外字エディタ」で編集するためです。

  「外字エディタ」で外字を作成するときは、縦横60ドットのビットマップを編集します。そこでなるべく綺麗に見えるように文字を作成しますね。そして保存するわけですが、このときに編集したビットマップデータがTrue Type というベクトルデータに変換されます。そして２つのファイルに保存されるのです。つまり、編集の際に使用したビットマップが eudc.eufに、True Type に変換されたデータが eudc.tte に、それぞれ保存されます。

  ベクトルデータとビットマップデータとの違いは簡単にいえば、拡大しても綺麗な文字が作れるのがベクトルデータ、拡大すると昔のワープロの２倍角４倍角文字のようにガタガタになってしまうのが、ビットマップデータです。

  tte というフォントファイル自体はTrue Typeフォントの形式になっているので、ちゃんとつくれば拡大しても美しい文字が作れるはずなのですが、「外字エディタ」 この編集方法に起因して、さほど美しい文字は作成できません。

  というのも ビットマップからTrue Type に変換される時の精度があまり高くないのです。というよりも、縦横60ドットのビットマップフォントをTrue Typeにしたところで、せいぜいこんなもんなのでしょう。

  さて、そういうわけで、外字ファイルは tte と euf のセットで一組になっています。セットになっていますが、外字エディタで編集する必要がない場合は、euf というファイルは必要ありません。また、外字ファイルの作者の意図で、編集をさせたくない場合もあるでしょう。

  その為、外字コピー屋さんではオプションを指定することにより、euf ファイルをコピーの対象としないようにすることができるようになっています。


外字とフォントのリンク

  Windows では、EUDC.TTE (とEUDC.EUF）が標準の外字ファイルです。

  しかし外字ファイルが１セットしかないと不便です。例えば外字を明朝体で作成してある場合、ゴシック体で文書の中では外字の部分だけ明朝体になってしまいますので、 大変に美しくない文書になってしまいます。明朝とゴシックだけならまだしも、毛筆系の文書の場合、その中に突然明朝体の文字が入ってきてしまうと、本当に興ざめします。

  Windowsでは、この問題をクリアするために、外字ファイルを複数作れるようになっています。そして、フォント毎に別の外字ファイルを割り当てることが可能になっています。 つまり、ゴシックフォントにはゴシックの外字、毛筆フォントには毛筆の外字を、それぞれ作成することができます。外字エディタでは、「フォントのリンク」というメニューでこれを行います。

  この場合、ユーザーは外字ファイルに自由に名前をつけて、それぞれのフォントにリンクさせることができます。たとえば、「MS ゴシック」用の外字には「ゴシック」などと名前をつけて保存することができます。すると、「ゴシック.tte」と「ゴシック.euf」の２つのファイルが作成されます。


外字ファイルの所在

  外字ファイルはどこにあるのでしょうか。これはOSによって少々異なってきます。標準的な位置は以下の表のようになっています。

   Windows 98, Me | Windows NT, 2000, Xp | 外字コピー屋さんがインストールする位置
OS標準の外字(eudc.tte) c:\windows c:\winnt\fonts, 又は
c:\windows\fonts 		OSに従う
フォントにリンクされた外字 | 任意 | 任意 | c:\winnt, 又はc:\windows

  ※ OSをインストールしたドライブによって、c:に限らず、d: e: ..... となる場合もある。

なお、エクスプローラで c:\windows\Fontsを開いても、外字ファイルの存在を確認することはできません。

その場合は、コマンドプロンプトを開いて、以下のようにすることで、確認することができます。（以下、Xpの場合)

>c:
>cd \windows\fonts
>dir eudc.*

これで eudc.tte と eudc.euf のファイルサイズや、編集日時が表示されます。

また、フォントにリンクされた外字は、外字エディタでは任意の場所に保存することができますが、外字コピー屋さんでは、煩雑をさけるため強制的に c:\windows 等にインストールします。c:\windows\fontsにインストールしないのは、前述のように、エクスプローラで確認できないのが不便だからです。


外字のレジストリ情報

外字のレジストリ情報は HKEY_CURRENT_USER\EUDC\932 にあります。

この中に、"SystemDefaultEUDCFont" という文字列値が、"EUDC.TTE"に設定されています。これが標準で使われる外字ファイルの名前という事になります。

また、外字ファイルとフォントをリンクしている場合は、フォント名称と外字ファイル名のペアが登録されます。

名前 | 種類 | データ
SystemDefaultEUDCFont | REG_SZ | EUDC.TTE
フォント名称 | REG_SZ | 外字ファイル名
〔例〕 |  |
HG正楷書体 | REG_SZ | E:\WINDOWS\楷書.tte
ＭＳ ゴシック | REG_SZ | E:\WINDOWS\ゴシック.tte

HKEY_CURRENT_USER 以下のキーに登録されるため、この設定はユーザー毎に異なる設定が可能です。

逆に、外字ファイルとフォントのリンクを全ユーザーで共通にするためには、ユーザー毎に同じ設定をし直さなければならないということになります。


Windows 2000 / Xp への対応について

Windows 98 / NT4.0 で作成した外字を、Windows 2000 / Xp　で使用する場合、以下のよう になります。ただし、これはあくまでも当方で確認した限りにおいてです。全ての場合に以下のようになるとは限りませんので、ご注意ください。

Windows 98/NT 4.0で作成した外字ファイルをWindows2000 / Xp にコピーした後、Windows2000の外字エディタを起動すると、外字ファイルの変換が行われ外字の拡張部分が使用できるようになります。

Windows 2000からは、unicodeで外字を扱うことができるようになり、使用できる文字数も大幅に拡張されたので、それに伴ってファイルの変換を行っているようです。

逆に、Windows 2000で作成した外字を98/NT4.0で使用することもできます。ただしunicode対応によって拡張された部分は使用することができません。

実際の運用では、Windows2000で拡張された部分をあきらめれば、外字ファイルを相互に交換しあうことができるようです。

なお、外字の拡張された部分を使用できるのはunicode対応ソフトだけです。

Windows2000 / Xp の場合、*.eufファイルが存在しない場合、外字エディタを起動してもすぐ終了してしまいます。外字の編集をしたい場合は、必ず*.eufファイルもコピーするようにしてください。


外字コード表

[外字コード表]ボタンをクリックすると、上図のような外字コード表が表示されます。

文字の上でマウスの左ボタンをクリックすると、ボタンを押下している間、文字を拡大して表示します。

表示するフォントを変更することもできますので、フォントと外字ファイルをリンクしている場合に容易に確認できます。

外字コード表を表示させたまま新しく外字をインストールすると、即座に外字が反映されるのが確認できるはずです。

Windows 2000 / XP で拡張された外字領域も表示できます。使用するコードをunicodeにするとすべての外字領域が表示可能となります。


トラブル・シューティング

Windows 2000 の Terminal Serviceのアプリケーションサーバモードで正常動作しない。

バージョン 2.5.8 以上をお使いください。

WordやExcelで外字を使うとハングル文字が表示されてしまう。

そういう仕様なのだそうです。マイクロソフトのサポート技術情報 417636 「NewGulimフォントがインストールされていると外字が使用できない」に対処方法が載っていますのでご確認ください。
要するに「New Gulim フォントを削除する」ということです。

他のマシンに外字をコピーしたが、そのマシンの外字エディタで、外字の編集ができない。

「*.EUF ファイルをコピーする」というチェックボックスにチェックを入れて、*.euf ファイル（たとえば、eudc.eufなど）もコピーしてください。このファイルがないと、外字エディタでは編集することができません。
  Windows 2000 / XP の場合は、外字エディタを起動してもすぐに終了してしまうようです。

他のマシンに外字をコピーしたが、そのマシンで外字が表示されない。

GUI版の外字コード表機能を使って、外字が更新されたかどうか確認できますので、それで確認してください。

本ソフトの外字コード表では外字が表示されているが、他のソフトでは表示できないのであれば、本ソフトの問題ではないように思われますが、とりあえずメールにてお知らせください。

他のマシンに外字をコピーしたが、そのマシンのMS-IMEのIMEパッドで外字が表示されない。（ワープロソフトなどでは表示されています。）

MS-IME98で起こりえる現象です。IMEパッドで表示するフォントを代えて試してください。

最初のバージョンのMS-IME98には外字の表示に関する不具合があり、すでにマイクロソフトからアップデートプログラムが発表されています。

マイクロソフトのダウンロードセンターにアクセスしてアップデートプログラムをダウンロードして、適用しください。

ダウンロードセンターでは、キーワードに、「IME」と入力して検索すると、簡単にアップデートプログラムを見つけることができます。

なお、他のバージョンのMSIMEを使用している場合でも、常に最新のバージョンにアップデートしておくことをおすすめいたします。

外字ファイルが大きすぎて、フロッピーに入りません。

なるべくFDに空き領域ができるように、余計なファイルは入れないでください。FDにcpeudc.exeとcpeu.exeの両方が入っている場合は、どちらか片方だけにしてください。（GUI版はcpeudc.exe）

それでもだめな場合は、ZIPやMOなどの大容量のメディアを使用するか、ネットワークの共有フォルダで実行してください。

本ソフトでは、複数のFDにわけて外字をコピーすることはできません。


更新履歴

Ver 2.5.8での変更点

Windows 2000 Server が Terminal Services の アプリケーションサーバーモードで動作している場合に対応しました。

外字コード表の些細な問題を修正しました。

Ver 2.5.7での変更点

外字取得の際、取得すべきファイルが一つも存在しなかったときのエラーについて対処しました。

Windows 2000/XPにおける、ＭＳ Pゴシックにリンクされた外字の定義を適正化しました。

外字コード表がunicodeに対応しました。

Ver 2.5.5での変更点

Windows XPの新インターフェースに対応しました。

コマンドライン版のサイズが約90Kbyteとなり、かなり小さくなりました。

動作自体は2.5.4から変化はありません。

Ver 2.5.4での変更点

Windows Me に対応しました。

外字コード表機能を追加しました。

存在しないファイルをコピーしようとして意味のわかりづらいエラーがでるのを避けるように修正しました。

その他、細かなバグを修正しました。

Ver 2.5.3での変更点

外字をゲットする、という表現をやめ、「取得する」という表現に改めました。

外字を取得、インストールする際、ファイルを上書きする前に、必ず問い合わせを行うようにしました。

ファイル上書きの問い合わせをしないようにするオプションを装備しました。


使用条件など

このソフトウェアはフリーウェアです。使用者は自由に使用できます。

雑誌やネットなどで再配布する場合は、かならず事前に連絡を下さい。無断の再配布はご遠慮ください。

また再配布の際に、配布形式（圧縮ファイルの内容）を変更することは固くお断り致します。

ご自分で作成した外字ファイルを配布するために、このソフトウェアを使用したい場合は、ご相談ください。

このソフトウェアを使用して何らかの損害があったとしても、当方ではまったく責任を負いません。

著作権は、East Valleyにあります。

バグや不具合などありましたら、下記まで連絡ください。

http://www.eastvalley.or.jp/
East Valley ソフトウェアコーナー
alioth@eastvalley.or.jp

Copyright © 1990-2005. East Valley.